const regex = /<[^>]*>(*SKIP)(*F)|(hello)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<[^>]*>(*SKIP)(*F)|(hello)', 'gi')
const str = `<div class="hello"> Hello world < hello world?! </div>`;
const subst = `<span style="background:yellow">$1</span>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);