#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<Content Include=".*?Thumbs.db.*?\/>"
Local $sString = "<Content Include="somepath1\somedir2\dir3\Thumbs.db" /> " & @CRLF & _
"" & @CRLF & _
"<Content Include="newpath\somedir2\Thumbs.db" /> " & @CRLF & _
"" & @CRLF & _
"<Content Include="anotherpath\somedir1\dir3\dir4\Thumbs.db" />" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<Content Include="anotherpath" />" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")