import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<Content Include=\".*?Thumbs.db.*?\\/>";
final String string = "<Content Include=\"somepath1\\somedir2\\dir3\\Thumbs.db\" /> \n\n"
+ "<Content Include=\"newpath\\somedir2\\Thumbs.db\" /> \n\n"
+ "<Content Include=\"anotherpath\\somedir1\\dir3\\dir4\\Thumbs.db\" />\n\n\n"
+ "<Content Include=\"anotherpath\" />\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}