$re = '/<Content Include=".*?Thumbs.db.*?\/>/';
$str = '<Content Include="somepath1\\somedir2\\dir3\\Thumbs.db" />
<Content Include="newpath\\somedir2\\Thumbs.db" />
<Content Include="anotherpath\\somedir1\\dir3\\dir4\\Thumbs.db" />
<Content Include="anotherpath" />
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);