const regex = /<Content Include=".*?Thumbs.db.*?\/>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<Content Include=".*?Thumbs.db.*?\\\/>', 'g')
const str = `<Content Include="somepath1\\somedir2\\dir3\\Thumbs.db" />
<Content Include="newpath\\somedir2\\Thumbs.db" />
<Content Include="anotherpath\\somedir1\\dir3\\dir4\\Thumbs.db" />
<Content Include="anotherpath" />
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}