use strict;
my $str = '<Content Include="somepath1\\somedir2\\dir3\\Thumbs.db" />
<Content Include="newpath\\somedir2\\Thumbs.db" />
<Content Include="anotherpath\\somedir1\\dir3\\dir4\\Thumbs.db" />
<Content Include="anotherpath" />
';
my $regex = qr/<Content Include=".*?Thumbs.db.*?\/>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}