using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<Content Include="".*?Thumbs.db.*?\/>";
string input = @"<Content Include=""somepath1\somedir2\dir3\Thumbs.db"" />
<Content Include=""newpath\somedir2\Thumbs.db"" />
<Content Include=""anotherpath\somedir1\dir3\dir4\Thumbs.db"" />
<Content Include=""anotherpath"" />
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}