package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<Content Include=".*?Thumbs.db.*?\/>`)
var str = `<Content Include="somepath1\somedir2\dir3\Thumbs.db" />
<Content Include="newpath\somedir2\Thumbs.db" />
<Content Include="anotherpath\somedir1\dir3\dir4\Thumbs.db" />
<Content Include="anotherpath" />
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}