// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<Content Include=".*?Thumbs.db.*?\/>"#).unwrap();
let string = "<Content Include=\"somepath1\\somedir2\\dir3\\Thumbs.db\" />
<Content Include=\"newpath\\somedir2\\Thumbs.db\" />
<Content Include=\"anotherpath\\somedir1\\dir3\\dir4\\Thumbs.db\" />
<Content Include=\"anotherpath\" />
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}