re = /<Content Include=".*?Thumbs.db.*?\/>/
str = '<Content Include="somepath1\\somedir2\\dir3\\Thumbs.db" />
<Content Include="newpath\\somedir2\\Thumbs.db" />
<Content Include="anotherpath\\somedir1\\dir3\\dir4\\Thumbs.db" />
<Content Include="anotherpath" />
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end