# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/"[^"\\]*(?:\\.[^"\\]*)*"(*SKIP)(*F)|\h+/$0\n/gm;t' <<< "arg1=ABC arg2=123 arg3= arg4=\"consecutive spaces and \\"escaped quote\\" shall be preserved within quotes\""