import Foundation
let pattern = #""[^"\\]*(?:\\.[^"\\]*)*"(*SKIP)(*F)|\h+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"arg1=ABC arg2=123 arg3= arg4="consecutive spaces and \"escaped quote\" shall be preserved within quotes""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$0\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)