package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"[^"\\]*(?:\\.[^"\\]*)*"(*SKIP)(*F)|\h+`)
var str = `arg1=ABC arg2=123 arg3= arg4="consecutive spaces and \"escaped quote\" shall be preserved within quotes"`
var substitution = "$0\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}