$re = '/"[^"\\\\]*(?:\\\\.[^"\\\\]*)*"(*SKIP)(*F)|\h+/m';
$str = 'arg1=ABC arg2=123 arg3= arg4="consecutive spaces and \\"escaped quote\\" shall be preserved within quotes"';
$subst = "$0\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;