const regex = /"[^"\\]*(?:\\.[^"\\]*)*"(*SKIP)(*F)|\h+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"[^"\\\\]*(?:\\\\.[^"\\\\]*)*"(*SKIP)(*F)|\\h+', 'gm')
const str = `arg1=ABC arg2=123 arg3= arg4="consecutive spaces and \\"escaped quote\\" shall be preserved within quotes"`;
const subst = `$0\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);