import re
regex = re.compile(r"\"[^\"\\]*(?:\\.[^\"\\]*)*\"(*SKIP)(*F)|\h+", flags=re.MULTILINE)
test_str = "arg1=ABC arg2=123 arg3= arg4=\"consecutive spaces and \\\"escaped quote\\\" shall be preserved within quotes\""
subst = "$0\\n"
result = regex.sub(subst, test_str)
if result:
print(result)