// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"[^"\\]*(?:\\.[^"\\]*)*"(*SKIP)(*F)|\h+"#).unwrap();
let string = "arg1=ABC arg2=123 arg3= arg4=\"consecutive spaces and \\\"escaped quote\\\" shall be preserved within quotes\"";
let substitution = "$0\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}