re = /"[^"\\]*(?:\\.[^"\\]*)*"(*SKIP)(*F)|\h+/m
str = 'arg1=ABC arg2=123 arg3= arg4="consecutive spaces and \\"escaped quote\\" shall be preserved within quotes"'
subst = '$0\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result