#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).*_D[1-9]?\d$"
Local $sString = "04R5714A_D15" & @CRLF & _
"" & @CRLF & _
"04R5714A_D05" & @CRLF & _
"" & @CRLF & _
"04R5714A_D5" & @CRLF & _
"" & @CRLF & _
"04R5714A_D5546" & @CRLF & _
"" & @CRLF & _
"04R5714A_D" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)