using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*_D[1-9]?\d$";
string substitution = @"";
string input = @"04R5714A_D15
04R5714A_D05
04R5714A_D5
04R5714A_D5546
04R5714A_D
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}