package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*_D[1-9]?\d$`)
var str = `04R5714A_D15
04R5714A_D05
04R5714A_D5
04R5714A_D5546
04R5714A_D
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}