import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*_D[1-9]?\\d$";
final String string = "04R5714A_D15\n\n"
+ "04R5714A_D05\n\n"
+ "04R5714A_D5\n\n"
+ "04R5714A_D5546\n\n"
+ "04R5714A_D\n\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}