const regex = /.*_D[1-9]?\d$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*_D[1-9]?\\d$', 'gm')
const str = `04R5714A_D15
04R5714A_D05
04R5714A_D5
04R5714A_D5546
04R5714A_D
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);