re = /.*_D[1-9]?\d$/m
str = '04R5714A_D15
04R5714A_D05
04R5714A_D5
04R5714A_D5546
04R5714A_D
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result