# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*_D[1-9]?\d$"
test_str = ("04R5714A_D15\n\n"
"04R5714A_D05\n\n"
"04R5714A_D5\n\n"
"04R5714A_D5546\n\n"
"04R5714A_D\n\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.