import Foundation
let pattern = #".*_D[1-9]?\d$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
04R5714A_D15
04R5714A_D05
04R5714A_D5
04R5714A_D5546
04R5714A_D
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)