# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\-\-\sSTART\n(.+?)\n\-\-\sEND/\1/gs;t' <<< "-- START
CREATE DATABASE IF NOT EXISTS feather_store_dev;
-- END
-- START
CREATE TABLE IF NOT EXISTS feather_store_dev.accounts (
id int,
email varchar(25),
bio varchar(18),
password varchar(32),
PRIMARY KEY (id)
);
-- END"