re = /\-\-\sSTART\n(.+?)\n\-\-\sEND/
str = '-- START
CREATE DATABASE IF NOT EXISTS feather_store_dev;
-- END
-- START
CREATE TABLE IF NOT EXISTS feather_store_dev.accounts (
id int,
email varchar(25),
bio varchar(18),
password varchar(32),
PRIMARY KEY (id)
);
-- END'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result