import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\-\\-\\sSTART\\n(.+?)\\n\\-\\-\\sEND";
final String string = "-- START\n"
+ "CREATE DATABASE IF NOT EXISTS feather_store_dev;\n"
+ "-- END\n\n"
+ "-- START\n"
+ "CREATE TABLE IF NOT EXISTS feather_store_dev.accounts (\n"
+ " id int,\n"
+ " email varchar(25),\n"
+ " bio varchar(18),\n"
+ " password varchar(32),\n"
+ " PRIMARY KEY (id)\n"
+ ");\n"
+ "-- END";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}