const regex = /\-\-\sSTART\n(.+?)\n\-\-\sEND/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\-\\-\\sSTART\\n(.+?)\\n\\-\\-\\sEND', 'gs')
const str = `-- START
CREATE DATABASE IF NOT EXISTS feather_store_dev;
-- END
-- START
CREATE TABLE IF NOT EXISTS feather_store_dev.accounts (
id int,
email varchar(25),
bio varchar(18),
password varchar(32),
PRIMARY KEY (id)
);
-- END`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);