using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\-\-\sSTART\n(.+?)\n\-\-\sEND";
string substitution = @"\1";
string input = @"-- START
CREATE DATABASE IF NOT EXISTS feather_store_dev;
-- END
-- START
CREATE TABLE IF NOT EXISTS feather_store_dev.accounts (
id int,
email varchar(25),
bio varchar(18),
password varchar(32),
PRIMARY KEY (id)
);
-- END";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}