# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\-\-\sSTART\n(.+?)\n\-\-\sEND"
test_str = ("-- START\n"
"CREATE DATABASE IF NOT EXISTS feather_store_dev;\n"
"-- END\n\n"
"-- START\n"
"CREATE TABLE IF NOT EXISTS feather_store_dev.accounts (\n"
" id int,\n"
" email varchar(25),\n"
" bio varchar(18),\n"
" password varchar(32),\n"
" PRIMARY KEY (id)\n"
");\n"
"-- END")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.