use strict;
my $str = '-- START
CREATE DATABASE IF NOT EXISTS feather_store_dev;
-- END
-- START
CREATE TABLE IF NOT EXISTS feather_store_dev.accounts (
id int,
email varchar(25),
bio varchar(18),
password varchar(32),
PRIMARY KEY (id)
);
-- END';
my $regex = qr/\-\-\sSTART\n(.+?)\n\-\-\sEND/sp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";