#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)attachment_types\":(\"|)\[(.*?)\]"
Local $sString = "foo Section 7 - Delivering Terminal Diagnosis's " & @CRLF & _
"" & @CRLF & _
"and then bar Section 7. Delivering a Terminal Diagnosis " & @CRLF & _
"" & @CRLF & _
"see Section 7. Delivering a Terminal Diagnosis " & @CRLF & _
"" & @CRLF & _
"filed under Section 7. Delivering a Terminal Diagnosis" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Section 7 - Delivering Terminal Diagnosis's " & @CRLF & _
"Section 7. Delivering a Terminal Diagnosis " & @CRLF & _
"" & @CRLF & _
"filed under Section 7. Delivering a Terminal and" & @CRLF & _
"see Section 7. Delivering a Terminal Diagnosis " & @CRLF & _
"" & @CRLF & _
"filed under Section 7. Delivering a Terminal Diagnosis" & @CRLF & _
""attachment_types":"[yada yada yada]" & @CRLF & _
""attachment_types":[yada yada yada]" & @CRLF & _
"" & @CRLF & _
"asf" & @CRLF & _
"a"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")