import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "attachment_types\\\":(\\\"|)\\[(.*?)\\]";
final String string = "foo Section 7 - Delivering Terminal Diagnosis's \n\n"
+ "and then bar Section 7. Delivering a Terminal Diagnosis \n\n"
+ "see Section 7. Delivering a Terminal Diagnosis \n\n"
+ "filed under Section 7. Delivering a Terminal Diagnosis\n\n\n"
+ "Section 7 - Delivering Terminal Diagnosis's \n"
+ "Section 7. Delivering a Terminal Diagnosis \n\n"
+ "filed under Section 7. Delivering a Terminal and\n"
+ "see Section 7. Delivering a Terminal Diagnosis \n\n"
+ "filed under Section 7. Delivering a Terminal Diagnosis\n"
+ "\"attachment_types\":\"[yada yada yada]\n"
+ "\"attachment_types\":[yada yada yada]\n\n"
+ "asf\n"
+ "a";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}