const regex = new RegExp('attachment_types\\":(\\"|)\\[(.*?)\\]', 'gi')
const str = `foo Section 7 - Delivering Terminal Diagnosis's
and then bar Section 7. Delivering a Terminal Diagnosis
see Section 7. Delivering a Terminal Diagnosis
filed under Section 7. Delivering a Terminal Diagnosis
Section 7 - Delivering Terminal Diagnosis's
Section 7. Delivering a Terminal Diagnosis
filed under Section 7. Delivering a Terminal and
see Section 7. Delivering a Terminal Diagnosis
filed under Section 7. Delivering a Terminal Diagnosis
"attachment_types":"[yada yada yada]
"attachment_types":[yada yada yada]
asf
a`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}