package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)attachment_types\":(\"|)\[(.*?)\]`)
var str = `foo Section 7 - Delivering Terminal Diagnosis's
and then bar Section 7. Delivering a Terminal Diagnosis
see Section 7. Delivering a Terminal Diagnosis
filed under Section 7. Delivering a Terminal Diagnosis
Section 7 - Delivering Terminal Diagnosis's
Section 7. Delivering a Terminal Diagnosis
filed under Section 7. Delivering a Terminal and
see Section 7. Delivering a Terminal Diagnosis
filed under Section 7. Delivering a Terminal Diagnosis
"attachment_types":"[yada yada yada]
"attachment_types":[yada yada yada]
asf
a`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}