// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)attachment_types\":(\"|)\[(.*?)\]"#).unwrap();
let string = "foo Section 7 - Delivering Terminal Diagnosis's
and then bar Section 7. Delivering a Terminal Diagnosis
see Section 7. Delivering a Terminal Diagnosis
filed under Section 7. Delivering a Terminal Diagnosis
Section 7 - Delivering Terminal Diagnosis's
Section 7. Delivering a Terminal Diagnosis
filed under Section 7. Delivering a Terminal and
see Section 7. Delivering a Terminal Diagnosis
filed under Section 7. Delivering a Terminal Diagnosis
\"attachment_types\":\"[yada yada yada]
\"attachment_types\":[yada yada yada]
asf
a";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}