import Foundation
let pattern = #"attachment_types\":(\"|)\[(.*?)\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
foo Section 7 - Delivering Terminal Diagnosis's
and then bar Section 7. Delivering a Terminal Diagnosis
see Section 7. Delivering a Terminal Diagnosis
filed under Section 7. Delivering a Terminal Diagnosis
Section 7 - Delivering Terminal Diagnosis's
Section 7. Delivering a Terminal Diagnosis
filed under Section 7. Delivering a Terminal and
see Section 7. Delivering a Terminal Diagnosis
filed under Section 7. Delivering a Terminal Diagnosis
"attachment_types":"[yada yada yada]
"attachment_types":[yada yada yada]
asf
a
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)