$re = '/attachment_types\":(\"|)\[(.*?)\]/i';
$str = 'foo Section 7 - Delivering Terminal Diagnosis\'s
and then bar Section 7. Delivering a Terminal Diagnosis
see Section 7. Delivering a Terminal Diagnosis
filed under Section 7. Delivering a Terminal Diagnosis
Section 7 - Delivering Terminal Diagnosis\'s
Section 7. Delivering a Terminal Diagnosis
filed under Section 7. Delivering a Terminal and
see Section 7. Delivering a Terminal Diagnosis
filed under Section 7. Delivering a Terminal Diagnosis
"attachment_types":"[yada yada yada]
"attachment_types":[yada yada yada]
asf
a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);