import re
regex = re.compile(r"attachment_types\":(\"|)\[(.*?)\]", flags=re.IGNORECASE)
test_str = ("foo Section 7 - Delivering Terminal Diagnosis's \n\n"
"and then bar Section 7. Delivering a Terminal Diagnosis \n\n"
"see Section 7. Delivering a Terminal Diagnosis \n\n"
"filed under Section 7. Delivering a Terminal Diagnosis\n\n\n"
"Section 7 - Delivering Terminal Diagnosis's \n"
"Section 7. Delivering a Terminal Diagnosis \n\n"
"filed under Section 7. Delivering a Terminal and\n"
"see Section 7. Delivering a Terminal Diagnosis \n\n"
"filed under Section 7. Delivering a Terminal Diagnosis\n"
"\"attachment_types\":\"[yada yada yada]\n"
"\"attachment_types\":[yada yada yada]\n\n"
"asf\n"
"a")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")