# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/import sel\./import sel.gen./g;t' <<< "package blah.foo.bar;
import org.blah.blah;
import sel.this.that;
import sel.boo.foo;
more text\";"