const regex = /import sel\./g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('import sel\\.', 'g')
const str = `package blah.foo.bar;
import org.blah.blah;
import sel.this.that;
import sel.boo.foo;
more text";`;
const subst = `import sel.gen.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);