use strict;
my $str = 'package blah.foo.bar;
import org.blah.blah;
import sel.this.that;
import sel.boo.foo;
more text";';
my $regex = qr/import sel\./p;
my $subst = 'import sel.gen.';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";