$re = '/import sel\./';
$str = 'package blah.foo.bar;
import org.blah.blah;
import sel.this.that;
import sel.boo.foo;
more text";';
$subst = "import sel.gen.";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;