// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"import sel\.").unwrap();
let string = "package blah.foo.bar;
import org.blah.blah;
import sel.this.that;
import sel.boo.foo;
more text\";";
let substitution = "import sel.gen.";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}