# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\.(woff|svg|ttf|eot)//g;t' <<< "app.svg
app.eot
app.woff
app.ttf"