re = /\.(woff|svg|ttf|eot)/
str = 'app.svg
app.eot
app.woff
app.ttf'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result