use strict;
my $str = 'app.svg
app.eot
app.woff
app.ttf';
my $regex = qr/\.(woff|svg|ttf|eot)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";