const regex = /\.(woff|svg|ttf|eot)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.(woff|svg|ttf|eot)', 'g')
const str = `app.svg
app.eot
app.woff
app.ttf`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);